tools-make/debian/rules
Nicola Pero f5bf6e4cb2 Updated for new special_prefix option
git-svn-id: svn+ssh://svn.gna.org/svn/gnustep/tools/make/trunk@9184 72102866-910b-0410-8b05-ffd578937521
2001-02-19 15:31:50 +00:00

71 lines
1.4 KiB
Makefile
Executable file

#!/usr/bin/make -f
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
# This is the debhelper compatibility version to use.
export DH_COMPAT=2
pkg = gnustep-make
tmpdir = $(shell pwd)/debian/$(pkg)
prefix = usr/lib/GNUstep
library_combo = gnu-gnu-gnu-xgps
build: stamp-build
stamp-build:
dh_testdir
./configure --prefix=$(prefix) --with-library-combo=$(library_combo)
$(MAKE)
touch stamp-build
clean:
dh_testdir
dh_testroot
rm -f stamp-build
: # configure, so that `make distclean' works
[ -f GNUmakefile ] || ./configure \
--prefix=/$(prefix) --with-library-combo=$(library_combo)
$(MAKE) distclean
dh_clean
install: build
dh_testdir
dh_testroot
dh_clean -k
dh_installdirs
$(MAKE) install special_prefix=$(tmpdir)
# Build architecture-independent files here.
binary-indep: build install
# We have nothing to do by default.
# Build architecture-dependent files here.
binary-arch: build install
dh_testversion 2
dh_testdir
dh_testroot
# dh_installdebconf
dh_installdocs NEWS README
dh_installexamples
# dh_installmime
# dh_installinit
dh_installcron
dh_installmanpages
dh_installinfo
# dh_undocumented
dh_installchangelogs ChangeLog
dh_strip
dh_compress
dh_fixperms
# dh_makeshlibs
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install