mirror of
https://github.com/chocolate-doom/debian.git
synced 2025-02-19 10:21:38 +00:00
Add dpkg-dev and cdbs to fake sarge build; add sched_setaffinity patch
for building on sarge. Subversion-branch: /debian Subversion-revision: 1473
This commit is contained in:
parent
53a8e4cbb3
commit
1717fbf526
3 changed files with 34 additions and 15 deletions
|
@ -34,6 +34,8 @@ add_pkg libsdl-mixer1.2-dev
|
|||
add_pkg libsdl-net1.2-dev
|
||||
add_pkg python-imaging
|
||||
add_pkg subversion
|
||||
add_pkg dpkg-dev
|
||||
add_pkg cdbs
|
||||
|
||||
debootstrap "--include=$pkgs" "$RELEASE" "$dest_dir" "$MIRROR"
|
||||
|
||||
|
|
29
debian/patches/00-affinity_fix.patch
vendored
Normal file
29
debian/patches/00-affinity_fix.patch
vendored
Normal file
|
@ -0,0 +1,29 @@
|
|||
Index: src/i_main.c
|
||||
===================================================================
|
||||
--- src/i_main.c (revision 1472)
|
||||
+++ src/i_main.c (working copy)
|
||||
@@ -76,6 +76,7 @@
|
||||
|
||||
// Linux version:
|
||||
|
||||
+#ifdef CPU_SET
|
||||
{
|
||||
cpu_set_t set;
|
||||
|
||||
@@ -84,9 +85,16 @@
|
||||
|
||||
sched_setaffinity(getpid(), sizeof(set), &set);
|
||||
}
|
||||
+#else
|
||||
+ {
|
||||
+ unsigned long mask = 1;
|
||||
|
||||
+ sched_setaffinity(getpid(), 1, &mask);
|
||||
+ }
|
||||
#endif
|
||||
|
||||
+#endif
|
||||
+
|
||||
// start doom
|
||||
|
||||
D_DoomMain ();
|
18
debian/rules
vendored
18
debian/rules
vendored
|
@ -2,6 +2,9 @@
|
|||
# Uncomment this to turn on verbose mode.
|
||||
#export DH_VERBOSE=1
|
||||
|
||||
include /usr/share/cdbs/1/rules/debhelper.mk
|
||||
include /usr/share/cdbs/1/rules/simple-patchsys.mk
|
||||
|
||||
# These are used for cross-compiling and for saving the configure script
|
||||
# from having to guess our platform (since we know it already)
|
||||
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
|
||||
|
@ -32,21 +35,6 @@ build-stamp: config.status
|
|||
touch build-stamp
|
||||
cd man && $(MAKE)
|
||||
|
||||
clean:
|
||||
dh_testdir
|
||||
dh_testroot
|
||||
rm -f build-stamp
|
||||
|
||||
[ ! -f Makefile ] || $(MAKE) distclean
|
||||
|
||||
# stuff we don't want in diff.gz
|
||||
find -name config.sub -print0 | xargs -0 -r rm -f \;
|
||||
find -name config.guess -print0 | xargs -0 -r rm -f \;
|
||||
|
||||
-cd man && $(MAKE) clean
|
||||
|
||||
dh_clean
|
||||
|
||||
install: build
|
||||
dh_testdir
|
||||
dh_testroot
|
||||
|
|
Loading…
Reference in a new issue